A Site for Photographers by Photographers

Community > Forums > Canon EOS > EOS Digital SLR Bodies > Off brand canon remote switch...

Featured Equipment Deals

Sigma 18-35mm F1.8 DC HSM Lens Review Read More

Sigma 18-35mm F1.8 DC HSM Lens Review

Sigma 18-35mm F1.8: Read why reviewer Rebekah Gough thinks this revolutionary lens is a "a game changer."

Latest Equipment Articles

Nikon D610 Review Read More

Nikon D610 Review

The affordable full-frame Nikon D610: how it stacks up against other Nikon cameras, how it performs, and why it might be a good choice for your next camera.

Latest Learning Articles

26 Creative Photos of Water Drops Read More

26 Creative Photos of Water Drops

These absolutely amazing macro photographs feature a tiny elemental thing that can hold a lot of mystery. Take a moment to enjoy these photographs of water drops.


Off brand canon remote switch w/ 20d

Tara Mauldin, Albemarle, NC , Jun 10, 2005; 08:00 p.m.

Hi! I hope this question hasn't been repeated too many times (I did a search and couldn't come up with any answers...) Has anyone had any luck with an off brand remote switch/cable release for their 20d? It looks so tempting to try an off brand @ $10.00 compared to $60 or so. I know you normally get what you pay for though. Anyone have any luck? Thanks! Tara :)

Responses

Joe Jarosz , Jun 10, 2005; 08:13 p.m.

Hi Tara, I haven't used a hard wired generic release, but I bought a wireless release off of ebay for my 20D and it works fine. It was about $100 compared to about $400 for the Canon one.

Hope this helps, Joe

Camilla Holm , Jun 10, 2005; 08:22 p.m.

I'm using one that I bought on Ebay. I think it's made by "Adidt". It works just fine. You have to switch the camera off to connect it. If you just plug it in, it doesn't work. That could be the case with the Canon remote aswell, I didn't try it. All in all, I am very happy with it, and it was around 20$ including shipping from China.

Steve Dunn , Jun 10, 2005; 08:33 p.m.

The wired remote is an extremely simple device: two switches, three wires, and a plug. That's it; no computers, no microchips, nothing fancy at all. Apart from a non-standard connector, it is exactly the same as the wired remote for the Elan (and similar) film bodies, and the plans for a DIY version of that have been on the Web for years so you can see how simple a device it is. It ought to be very simple to make a fully functional third-party equivalent, and actually rather difficult to make one which doesn't work properly.

Never having used one of the third-party remotes, I'd have to guess that there are two reasons why they're so much cheaper than Canon's. The first is that it doesn't have the Canon name on it; the actual parts and manufacturing cost of the Canon one is probably 1-2% of the retail price, with transportation accounting for some more of the cost and profit being most of the price. The other is that perhaps they use low-quality switches which will become flaky, and low-quality wire which will break, after you use it for a while.

In response to previous questions similar to yours (yes, there have been many, but I suspect it would be hard to come up with a search which would return those articles without also returning a whole bunch of other unrelated ones), lots of people seem to have used the cheap Chinese knockoff with success.

Christopher Bibbs , Jun 10, 2005; 08:46 p.m.

I'll second the vote of confidence for the Adidt remote. It works as well as needed and is a better price than the Canon unit.

James Colwell , Jun 10, 2005; 09:01 p.m.

I third it.

Daniel Taylor , Jun 10, 2005; 10:34 p.m.

I went with Canon's Timer remote. The features are worth $132 (B&H).

patrick tom , Jun 11, 2005; 12:06 a.m.

Hello...I agree...they work pretty good...I'm on my third one...not because of failure...I've lost two of them...absent mindedness...

Tom Flores Sr , Jun 13, 2005; 12:12 a.m.

Bought the Adit on Ebay. Works just fine. :-)

Tara Mauldin, Albemarle, NC , Jun 28, 2005; 10:09 a.m.

Thanks to everyone who gave me some advice. I went with the off brand and it seems to be working just fine!

Back to top

Notify me of Responses