A Site for Photographers by Photographers

Community > Forums > Canon EOS > EOS Lenses > 70-200 2.8 IS lens won't...

Featured Equipment Deals

Basic Image Development in Lightroom: Color Editing (Video Tutorial) Read More

Basic Image Development in Lightroom: Color Editing (Video Tutorial)

Learn basic HSL (hue, saturation, and luminance) color adjustments as well as split toning (adjusting color in highlights and lowlights) in this next video.

Latest Equipment Articles

10 Stocking Stuffers under $50 Read More

10 Stocking Stuffers under $50

We've searched high and low to put together this list of 10 small photo-related gifts that any photography lover would be delighted to receive. No matter your budget, these are also fun to give (or...

Latest Learning Articles

State of the ART: The Little Lens That Could Read More

State of the ART: The Little Lens That Could

Fine art photographer Pete Myers talks about his love for the Cosina Voigtländer CV ULTRON 40mm SLii, a lens he considers to be "The Little Lens That Could."


70-200 2.8 IS lens won't AUTOFOCUS - anyone else had problems?

david baird , Aug 02, 2006; 05:29 p.m.

Hi all,

I've very recently purchased a Canon 70-200 2.8 IS lens and for some reason it isn't autofocusing. It's pointing at nice, clear, contrasty things, and will focus in manule mode, but doesn't focus in auto mode, just makes a pathetic slow attempt then gives up...

(This happens on two different SLRs, and doesn't happen when I put on different lenses)

Has anyone else had this issue?

Am I doing something daft? It is late, I am tired... but this should be very simple....!

Thanks for any help you may be able to give...

David

Responses

Puppy Face , Aug 02, 2006; 05:35 p.m.

Is the limiter set to restrict AF distance?

Giampi . , Aug 02, 2006; 05:58 p.m.

Try swtiching the AF "off" then "on" again.

James Colwell , Aug 02, 2006; 06:17 p.m.

The auto focus (AF) speed, AF accuracy and image quality from my 70-200 IS are fantastic. If your AF still farts around after cleaning the lens contacts, then it's time for either (i) service, or (ii) to return it.

Mark Nagel , Aug 02, 2006; 09:27 p.m.

Check your limiter switch, cycle the AF switch and make sure you are focusing on something farther than the minimum focus distance. If not that? ? ? ?

m

Dan Funk , Aug 02, 2006; 10:01 p.m.

All of the above

And if it still doesn't work _after cleaning the lens' contacts_ then send it back.

--

Giampi . , Aug 03, 2006; 10:42 a.m.

BTW, let us know how you solved the issue. That way other users can benefit from this thread.

John Steggall , Aug 04, 2006; 07:58 p.m.

I have the non-IS version and it's a little over a year old. On my Rebel XT body, it refuses to autofocus about one in ten times when I first turn the camera on. I had this problem when it was new and don't have any problems with my other two lenses (50 f1.4 & 17-40 f4L). I probably should have returned it but need to use it so often that I'm not willing to go without it. Anyway, I have tried everything -- cycling the AF/MF switch, removing/attaching the lens, power cycling the body, and playing with the manual focus ring. Each of these "solutions" seems to have fixed it at some time but none are reliable. Problem is that I'm usually in a panic when it doesn't work and am trying everything at once (and then I promptly forget about the problem when it starts working). Obviously, I need to do a controlled experiment...

Back to top

Notify me of Responses