A Site for Photographers by Photographers

Community > Forums > Canon EOS > EOS Digital SLR Bodies > Canon Rebel XT "Error 99" at...

Featured Equipment Deals

Conservation Photography: The Power of Pictures Read More

Conservation Photography: The Power of Pictures

On Earth Day, wildlife photographer Chris Weston explains how photographs have the power to bring people together and create change.

Latest Equipment Articles

Lensbaby Spark Review Read More

Lensbaby Spark Review

This inexpensive gadget does indeed spark your creativity. Read on to see how.

Latest Learning Articles

26 Creative Photos of Water Drops Read More

26 Creative Photos of Water Drops

These absolutely amazing macro photographs feature a tiny elemental thing that can hold a lot of mystery. Take a moment to enjoy these photographs of water drops.


Canon Rebel XT "Error 99" at every 5th shot

Responses


First     Prev     1   |   2   |   3   |   4     Next    Last

Chris JB , Mar 09, 2008; 06:00 a.m.

Maybe reload the firmware. I`m not a computer expert, but sounds currupt somewere in the memory. or a call to canon.

William W , Mar 09, 2008; 09:07 a.m.

>>> Start by removing and re-inserting main battery. <<<

Take BOTH batteries out and leave out overnight.

Reinsert both batteries.

[Assuming you have reloaded the firmware]

If still stuffed send it to Canon.

My guess: Mirror Box Assembly, it displays error 99 too, (well it did for me, but was intermittent for only three frames then died completely.)

Keep us informed, please. Good Luck

WW

Michael Liczbanski , Mar 09, 2008; 10:30 a.m.

Send it to Canon. Unfortunately pretty much all digital camera manufacturers have decided to follow the footsteps of computer makers and instead of reporting extended error conditions in plain language, we get "Error99." (Yeah, there is a need for a catch-all error because like all complex systems digital cameras are testable, but by no means are ever fully tested. Still...)

Mendel Leisk , Mar 09, 2008; 01:32 p.m.

Tried reloading firmware: 1.0.3 to 1.0.3. Took four shots, crossed fingers, took fifth shot: no joy ;(

Will try taking out both batteries now.

I see new Rebel XT's are $394US at B&H. Also looking at the XTi, and see there is an Xsi on the horizon. I'm a bit uneasy about another Rebel purchase at this point, tho...

Hmm, the Rebel's are cool little cameras: this is our son's camera, and it's the first time I've played around with it. I like the menu structure better (compared to 20D/30D/40D/5D format), with the columns accross the top allowing you to jump to the menu sub-catagories, and most if not all individual menu items then available without scrolling. Neat little camera.

Mendel Leisk , Mar 09, 2008; 01:57 p.m.

Changed File Numbering from Continuous to Auto Reset. No more "Error 99" at fifth shot. Breakthrough! :)

Changed back to continuous: "Error 99" back, at fifth shot. :(

Changed back to Auto Reset: "Error 99" persists, at fifth shot. Setback! :|

Mendel Leisk , Mar 09, 2008; 02:15 p.m.

Took *both* batteries out for a minute or two. When replaced, the camera indicate low battery state, all of a sudden. Maybe the camera has been falsely optimistic about battery state, and removal of both batteries has reset this. The (big) battery has never been replaced on this camera. Grasping at straws.

Now that I know *where* the little battery is, I'll leave *both* out for a proctracted time interval, per William's suggestion, and get the big one fully charged, and see how it goes.

Still, I'm sure I was on to something, changing file count from "continuous" to "auto reset". Nice while it lasted...

Kevin Break , Mar 09, 2008; 04:59 p.m.

I know this sounds peculiar, but put the body without batteries into a plastic ziplock bag and freeze for at least an hour.
Take it out and let the condensation occur onto the baggie for about 20 minutes, reinsert batteries and see if it works.

I am amazed how often this will get results with electronics.

Mendel Leisk , Mar 09, 2008; 06:19 p.m.

I can't bring myself to do it, yet...

Marco Suarez , Mar 11, 2008; 05:30 p.m.

Mendel,

Try this - set the camera to A mode and put the aperture as high as it goes (f22 or higher). Fire a shot, it should give you err99. If it does it is a bad aperture assembly on the lens. If it is doing it without a lens then most likely a bad shutter and the shutter will have to be replaced - no self fix there. The fifth shot err99 just sounds like a strange coincidence as err99 is usually random, not at predisposed intervals but i guess if one of the shutter blades is warped it could cause the shutter to fail after a set number of shots.

Good Luck

Mark

Mendel Leisk , Mar 12, 2008; 03:14 p.m.

Thanks, Mark. I'll think about that. It's for sure not the lens tho (I wish it was): at the latest I've just been shooting in manual, with no lens attached and the body cap on. Also, I did a few shots with mirror lock up on, and after the first shutter depression had a good look at the exposed shutter. It "looked" fine: flat and even spaced blades.

A stumper. And yes, it every fifth shot that results in error message, very strange. One time, upon changing the shot counter from continuous to auto-reset, I got past the 5 shot barrier. But then, with subsequent switches between shot counting modes, there was no difference.

Kevin, et all, I tried putting it in the freezer for an hour. Then left it sitting almost a day sans *all* batteries, *and* crossed my fingers when testing the result, but no change ;(

I emailed Canon Canada an extensive email explaining in detail the symptoms. They sent back the form letter to send it in, they'll provide free estimate. I think a human being gave my email a cursory glance and then pushed a button to generate their response.


First     Prev     1   |   2   |   3   |   4     Next    Last

Back to top

Notify me of Responses