A Site for Photographers by Photographers

Community > Forums > Canon EOS > Help - my 40D won't download...

Featured Equipment Deals

Portrait Photography - Part I (Video Tutorial) Read More

Portrait Photography - Part I (Video Tutorial)

Learn the basics of Portrait Photography, specifically the ideal equipment, composition considerations, and location settings for this type of photography.

Latest Equipment Articles

4 Outdoor & Adventure Photo Packs Read More

4 Outdoor & Adventure Photo Packs

Photo packs have come a long way in the past decade, especially those that are targeted toward outdoor and adventure photographers. Alaska-based adventure photographer Dan Bailey takes a closer look...

Latest Learning Articles

A Brief History of Photography - Part II (Video Tutorial) Read More

A Brief History of Photography - Part II (Video Tutorial)

This video explores the second half of photography's history and development from the technological advances in the late 1800s through the beginnings of digital photography at the end of the 20th...


Help - my 40D won't download photos to my Mac...

Emma Millen , Jun 15, 2008; 04:53 p.m.

My MAC doesn't seem to recognise my Canon 40D and so I can't download any photos. It used to work fine through Bridge and the EOS Utility software that I have installed but has suddenly stopped working. When I open the photo downloader in Bridge it says "get photos from" and then it says "none detected" when I open the EOS Utility it doesn't give me the option to download the images. My camera says BUSY on the screen on top of the camera when I first plug it in to the computer but after about 10 seconds it goes back to the normal display and doesn't download anything. I'm not sure if it is a camera problem, lead problem (both are new) or MAC problem. Any help greatly appreciated.

Thanks

Responses

Richard Crowe , Jun 15, 2008; 05:00 p.m.

I suggest that you get a card reader and use that to download your images. Card readers are very inexpensive and work very well.

I have been using a PNY Compact Flash reader for a long while now and it has never let me down.

Puppy Face , Jun 15, 2008; 05:37 p.m.

Card reader dude.

Also, you need to practice regular disk maintenance--rebuild permissions, rebuild directory with Disk Warrior, toss corrupt preferences, etc.--or you've cruising for bruising. I do it at least once a month and never have problems. My sister never does it and I have to recover her HD every year or two...

Steve Torelli , Jun 15, 2008; 06:37 p.m.

" Use a card reader" should be on the opening page right after "Welcome to Photo net."

Jon Erickson , Jun 15, 2008; 08:09 p.m.

A card reader should speed things up a bit, generally speaking.

But to understand perhaps what's going when you plug in your camera, launch Image Capture (no need to connect your camera). A window should pop up: "No Image Capture device connected." Open the application's preferences (Command-comma) and see what is selected under "Camera: When a camera is connected, open:". Here you should be able to set the application of choice (Bridge, iPhoto, Lightroom, etc.)

You don't need the EOS utility at all.

Eric Ferreira , Jun 16, 2008; 12:20 a.m.

This happens to me when there is another user logged in. I switch to that user and the camera gets detected there.

Frank Ernens , Jun 16, 2008; 03:33 a.m.

Jon's answer is the right one. This is exactly the problem people have been having with the 5D and Canon's software on Leopard (OS X 10.5, as shipped with any recent Mac).

The advice top get a card reader may be appropriate for PC users, but not for the typical amateur photographer using a Mac, since OS X comes with software ("Image Capture", as already mentioned) to upload images from Canon cameras and many or most of the card readers around are not up to the quality and reliability standards expected by Mac users. Yes, uploading via a USB cable slower, but you can leave it and go cook dinner.

You should get it working with the USB port. If it is faulty, one probable cause would be a cracked circuit board. You want to track that down now, not after the warranty expires.

Puppy Face wrote:

you need to practice regular disk maintenance--rebuild permissions, rebuild directory with Disk Warrior, toss corrupt preferences, etc.--or you've cruising for bruising.

None of this is necessary, especially "rebuild permissions".

Frank Ernens , Jun 16, 2008; 03:59 a.m.

I should add that I am guessing here that "EOS Utility" is somehow screwing things up for Adobe's software (which works for the 5D - I use it), and that after using Jon's method to take control away from it you might need to reboot.

If "EOS Utility" is really badly behaved you might need to do more to disable it - ask again here.

Susan McCullough , Feb 16, 2014; 02:52 p.m.

I have had the problem others have described where my Canon EOS40D has difficulty communicating with iPhoto. I set it up as I always have, the way it has worked very well in the past, the camera flashes “busy,” but no photos appear in iPhoto.

Here is a solution that has worked for me. Please, don’t take offense at the simplicity of this. I noticed that my camera battery was low. I put a recharged battery into the camera, and the photos flowed fast and without a glitch, to iPhoto. I hope this saves someone else from wasting a lot of time and getting increasingly frustrated, fussing with many high tech solutions.

Back to top

Notify me of Responses