A Site for Photographers by Photographers

Community > Forums > Digital Darkroom > Scanning>Software > silverfast does not launch

Featured Equipment Deals

Navigating Lightroom: The Web Mode (Video Tutorial) Read More

Navigating Lightroom: The Web Mode (Video Tutorial)

Lightroom's Web Mode allows you to create a gallery that can be directly uploaded to your website. Learn how to use this feature in this video tutorial.

Latest Equipment Articles

4 Outdoor & Adventure Photo Packs Read More

4 Outdoor & Adventure Photo Packs

Photo packs have come a long way in the past decade, especially those that are targeted toward outdoor and adventure photographers. Alaska-based adventure photographer Dan Bailey takes a closer look...

Latest Learning Articles

5 Tips for Combating Red-Eye Read More

5 Tips for Combating Red-Eye

Red-eye doesn't have to ruin your photos. Learn 5 simple tricks to avoid and eliminate this undesirable photographic effect.


silverfast does not launch

burak savak , May 21, 2009; 01:17 a.m.

Hi,
I am having a strange problem with my new laptop.
Silverfast does not work with it, I tried the same slverfast with my old PC and works like champ.
However with the laptop, launch manager comes up and I chose silverfast, than another screen appers giving copule messages like "now silverfast is looking for scanners" etc, and disappears.
I think it dies for some reason. I tried to remove most of the pheriperals especially usb ones) No good.
has anyone else encountered such problem? if so what was the remedy?
Regards,
-b.

Responses


    1   |   2     Next    Last

Mike Hitchen , May 21, 2009; 08:22 a.m.

I have had that message when the scanner is not plugged into the computer (or not turned on) so I have to make sure it is turned on before opening SF. These simple suggestions are the only ones I can offer.

Wolf Weber , May 21, 2009; 08:31 a.m.

First, are the OS versions of the old PC and the new laptop identical..? SF is known to charge for upgrades when a User goes to a more recent OS. Same goes for the scanner, whichever make or model, usually without a charge. The driver might have to be updated. It's a never ending story.

Scott Turner , May 21, 2009; 08:59 a.m.

What scanner, and what OS? If you're using a Nikon scanner, and Vista64, for example, SF won't see the scanner, as the Nikon drivers which SF uses don't work on Vista64.

The more information you provide, the better chance that someone here can help.

Scott

peter carter , May 21, 2009; 10:06 a.m.

I am currently having that discussion with SF and has lasted for about a month so far with no resolution except turn everything else off - insinuating it can't be their software. What kind of a solution is that when every other software works and finds the scanner(s). I don't get warm fuzzy feelings with them. Sadly I bought their Ai software twice ($$$), one for each of my scanners. Some customer support.

ps; my $70 vuescan works like a champ.....and they get back to me within a day when there was a question. They could learn a lesson.

William Kahn , May 21, 2009; 10:15 a.m.

I launch Silverfast (AI6 Studio) as a Photoshop plug-in. The only time I've had a similar problem is when I forget to turn the scanner on before launching. Also, if you're using a scanner with an SCSI connection instead of USB or Firewire, you need to turn the scanner on before booting up the PC. Have you checked to see if the scanner is actually recognized by the PC before launching Silverfast?

Oh, and I've never had a problem with Silverfast customer service, either..... :-)

Bengt Ekelberg , May 21, 2009; 12:34 p.m.

Are you logged on as an administrator? After updating my Silverfast to the latest version, it will only launch when I'm logged on as administrator...

Scott M. Knowles , May 21, 2009; 06:12 p.m.

I can't add much to this discussion except as noted, the scanner must be turned on, and if it still can find it, it's likely in need of an updgrade for the new OS version. I run AI 6 Pro IT8 on two scanners on a Mac G5 PPC and rarely had a problem with updates and then always got quick and good help from SI, and in every case the problems are on my end with the configuration or something. As for running, I'm also administrator which saves time with software installations or updates, but if it doesn't run under a user account, it's likely permissions.

But I agree too, more information from the originator of the thread would help. Otherwise we're talking to ourselves.

Frank Meyers , May 27, 2009; 06:27 a.m.

[quote]"... SF is known to charge for upgrades when a User goes to a more recent OS. ..."[/quote]
This is not true. You can change your operating system w/o having to buy a new license or upgrade.

But you have to download the fitting installation file. Burak, if you can't fix things on your own, ask the LaserSoft suport team for help as Scott recommended. I also have made good experiences only.

peter carter , May 27, 2009; 09:08 a.m.

A quote from my last support email....

The manufacturer's software use different channels for communicating with the scanner; SilverFast uses one - this is the reason for interference when other scanners are connected.
This is not an actual bug, it is merely the result of the current programming.

I just love that last line. It doesn't work, but it's not a bug.... If software doesn't work properly, is that not a bug?

Now I have been persistent, which led to...

I will see to it, that you will get the next upgrades for free - regardless if it is a free upgrade or one for which we charge a fee.

So FrankM, they are not admitting to a bug but acknowledge that a "change" may be a feature for a new version to require an upgrade. It's perspective and how they see the world. My concern stemmed from them insisting it was not a bug, allowing them the latitude of not having to fix the situation and charging me for the "new" version.

My frustration is that it took a month and a half to get here when I have only owned the product for a month and a half. I had a previous version for a year with no issues. I was happy then. It's one thing to have a product that is broken, it's another to put your clients through this. It goes to show you never know a company until something goes wrong.

In summation, if it is your fault their support will fix you fast. If it is theirs, it will take forever to get them to admit a problem and then to do something.

Burak, your problem is amazingly similar to mine. I wish you more luck than mine.


    1   |   2     Next    Last

Back to top

Notify me of Responses