A Site for Photographers by Photographers

Community > Forums > Digital Darkroom > Software>Editing > Nikon Capture NX2.3.0 is out...

Featured Equipment Deals

The June Monthly Project Read More

The June Monthly Project

This month we are putting ourselves in front of the lens for a project on the self-portrait with guest instructor Jackie DiBenedetto. Please add your photo to the thread and enjoy the conversation....

Latest Equipment Articles

From Light to Ink: An Exhibit Using Canon's imagePROGRAF printers Read More

From Light to Ink: An Exhibit Using Canon's imagePROGRAF printers

"From Light to Ink" featured the work of Canon Inspirers and contest winners, all printed using Canon's imagePROGRAF printers. The gallery show revolved around the discussion of printing photographs...

Latest Learning Articles

How to Get the Most Out of a Photography Workshop Read More

How to Get the Most Out of a Photography Workshop

Attending a photography workshop can be a great way to take your images to the next level, but it can also be a big investment in time, money, and travel. By following these 7 simple tips, you can...


Nikon Capture NX2.3.0 is out ...

Tom Mann , Dec 20, 2011; 02:24 p.m.

... and it seems to have fixed the incredibly frustrating problems I had been having with 2.2.8, at least on the 1st two images that I tried. Let's see if it keeps working.

Download from here:
https://nikoneurope-en.custhelp.com/app/answers/list

My post lamenting the problems with 2.2.8, coincidentally posted just minutes before I heard that 2.3 was out:
http://photo.net/digital-darkroom-forum/00ZlHs

Tom M

Responses

Tom Mann , Dec 20, 2011; 02:24 p.m.

.

Tom Mann , Dec 20, 2011; 02:53 p.m.

Sorry to get everyone's hopes up, but 2.3 didn't fix the problem. I exercised the new version on a few images and it started to crash regularly again. See the thread dealing with the problem:
http://photo.net/digital-darkroom-forum/00ZlHs

:-(

Tom M

Wayne Cornell , Dec 20, 2011; 09:02 p.m.

Loaded the new version. It doesn't crash on my Win 7 64 bit computer but then the other versions didn't either.

Chris Letts , Dec 21, 2011; 10:33 a.m.

I believe I've posted this answer before, but worth repeating that although I've NEVER had problems with NX2, I have consistently had problems with the 'Nikon Message Centre'. The message centre is loaded by default when loading NX2, so it's worth uninstalling the Message Centre to see if that solves your problems.

By the way this new NX2 claims to be truly 64 bit at last so I'm looking forward to using it..

Dave Lee , Dec 21, 2011; 11:48 p.m.

I have it running on my iMac with 10.6.8 and it is a true 64bit application. Nice.

Chris Letts , Dec 22, 2011; 05:22 a.m.

Loaded it up last night and can confirm that on my Win7 64bit, it's WAY faster than before. 64bit users - you HAVE to have it...

Janos Kovacs , Dec 23, 2011; 02:36 p.m.

Works definitely faster on 64bit Win 7. I have no problems with Captur NX, never had major problems.

Eddie Cheng , Dec 25, 2011; 07:12 p.m.

Good day,
I've updated from NX2 2.2.8
My optional picture controls ~ landscape & portrait ~ are missing. Tried installing and it throws me a message that a same version exists. If I force it (continue installing), an error message '... \License_EN_OPC100.rtf was not found'.
I am running a 64-bit W7.
Any help please? Thank you.

Tom Meyer , Jan 07, 2012; 10:58 p.m.

Sorry, no help here. I had quit using NX2 because it was just too slow and frustrating. After I read a review that reported efficiency gains of up to 700% with certain actions, I reloaded NX2, and the downloaded the upgrade... It did say I had a more recent version loaded in, which I didn't but gave the OK to overwrite and all is good. This all on Win7 64Bit. I haven't used it yet except to confirm functionality, and will use it only for files that Lightroom might struggle with. Perhaps I'll try some recent portraits... t

Back to top

Notify me of Responses