A Site for Photographers by Photographers

Community > Forums > Medium Format > Mamiya RB/RZ > 110mm lens shutter blades...

Featured Equipment Deals

State of the ART: The Purpose of Fine Art Photography Read More

State of the ART: The Purpose of Fine Art Photography

Fine Art photographer, Pete Myers, discusses fine art photography in his first of four installments.

Latest Equipment Articles

Sun Position Tracking Apps Read More

Sun Position Tracking Apps

These 5 apps, ranging in price from free to $8.99, are our top picks for tracking sun (and moon) light. Also ranging in complexity, some help you keep tabs on the ideal lighting of the day while...

Latest Learning Articles

Advanced Printing with Lightroom (Video Tutorial) Read More

Advanced Printing with Lightroom (Video Tutorial)

Building upon last week's Basic Printing with Lightroom video tutorial, this advanced printing tutorial will teach you to print contact sheets, print multiple images at a time, use Lightroom's present...


110mm lens shutter blades won't open

Cian Perez , Apr 19, 2011; 05:13 p.m.

Hello gang -

Hoping you could help me with a problem I'm having with my 110mm/f2.8 W RZ67 lens. I am using the lens on a RZ Pro II. I am just now getting acquainted with this body and lenses (bought it over a year ago). I have read the RZ Pro II manual as well as many of the troubleshooting threads here. I even have Bob Shell's Mamiya book and have read the appropriate sections in there as well.

I have three lenses:
> 65mm/f4 K/L L RB
> 110mm/f2.8 W RZ
> 180mm/f4.5 W-N RZ

The 65mm RB and 180mm RZ lenses are functioning properly. I can see through the WLF, focus, and trigger the mirror/shutter successfully in M mode at various shutter speeds and apertures. The camera itself also seems to behave as expected with the warning lights (more on this later) when a condition presents itself to not allow the release of the mirror.

My problem is with the 110mm lens. The shutter blades seem to be stuck in the closed position. At first, I thought this may have been a battery issue, but the 180mm lens functions as expected on the Pro II body. I then tried to use the 110mm lens in the emergency (fixed 1/400th shutter) mode, but no luck. The blades are still closed. From viewing through the back of the lens, I can activate the DOF preview just fine. I have cocked and released the lens manually multiple times but the shutter blades still won't open.

Concerning the battery - It seems strong enough to allow the lights to function on the Pro II body but I cannot hear any beeping. Is it supposed to beep? I have some new batteries on order, but again, the shutter blades on the 110mm lens are still fully shut when installed or detached from the camera body so a battery issue may not be the culprit.

I tried holding the lens alone with the shutter trigger release button/nib pushed down and giving it light taps/bumps but that didn't work either. Anything else I can try on the lens itself to release the blades?

Thanks!

Responses

Marc Batters , Apr 19, 2011; 08:36 p.m.

It's probably a lens with a bad shutter, and the lens may need a new shutter assembly installed.
When installing a lens onto the body, remember the body must be cocked and the lens must be pre-cocked. Also, when swapping from RB to RZ lenses, the shutter speed dial on the RZ camera body must be turned to something other then the RBL setting, (ie...select a shutter speed).
The camera should beep for things like low battery, mirror dropping, or MLU one minute warning, etc...
I believe, based on the price that 110mm lenses still command on the used market, repairing a 110 lens that is in otherwise good condition, is just a little cheaper then buying a used replacement lens. YMMV

Cian Perez , Apr 19, 2011; 11:37 p.m.

A bad shutter assembly? I was afraid of that. I was aware of all those other points you made, so the bad shutter is starting to be the obvious culprit.

I'll see how much local a reputable facility will charge for the repair. I can visibly see the shutter blades and they do not appear misaligned or mangled, so hopefully they're simply "stuck".

Thank you, Marc.

Andre Noble , Apr 20, 2011; 01:31 a.m.

Send it to Mamiya America Corp for repair quote. The problem may not be as serious as having to replace the shutter assembly. In fact, in recently talking to a Mamiya repair man about the very issue of Mamiya RZ and RB shutter reliability and repair - he said that it is relatively rare when repairing the shutter that the whole unit needs to be replaced - contrary to what you often read on this forum about these lenses being plastic, cheap and unrepairable.

Marc Batters , Apr 20, 2011; 03:35 a.m.

Cian, Mamiya America would be my choice of last resort for repair of a used RZ lens.
Their prices range from $254. to $479.USD for lens repair work. Used 110mm lenses in good operating condition, (some with warranties), can be purchased from many different sellers on the web, for far less money then MAC charges just for repairing the lens, plus you will also have round trip shipping fees on top of that.
MAC RZ Fees
(link)
Alpine Camera, WA. If you can't find a local shop, give these folks a call.
http://www.alpinecamera.com/repair_info.htm
From P-Net Testimonial's
(link)

Cian Perez , Apr 20, 2011; 11:02 a.m.

Thanks gentlemen. I live near Chicago, and from a quick search on the web there appears to be a few reputable repair facilities here. Not surprising, given the size of the population as well as the number of serious/professional photographers in the area. Also, I already have a few contacts to pursue based on past threads here. I'll report back on what I find.

Andre Noble , Apr 21, 2011; 12:28 p.m.

Marc, I see your point.

Cian Perez , Jun 14, 2011; 09:37 a.m.

Just an update. I dropped off the lens at International Camera in downtown Chicago. They had a few endorsements in this forum. The quote to repair was $178. My lens was still very minty. Given a replacement used lens is nearly twice the cost, I'll opt for the repair.

Cian Perez , Jul 23, 2011; 01:21 a.m.

I picked up my camera and lens from International Camera earlier in the week. It didn't take this long to fix (one month). It's just that it took me this long to find time to get back into the city to retrieve it.
I did speak to them when they called to followup and convey that they were done with the lens repair (approximately a week after I dropped the camera off), and they said they would CLA the body for free since they had it on the bench with the lens. (I forgot to mention prior that they requested to keep the body as well to make sure it wasn't a problem on my RZ67 Pro II.) They do all their own repairs in-house. They don't farm it out. They even do repairs on digital bodies.
Anyway, the shutter on my 110/2.8 does open and close as expected now. I haven't put any film through it yet, but visually everything is functioning as it should. So far so good.

Back to top

Notify me of Responses