A Site for Photographers by Photographers

Featured Equipment Deals

Digital Photography Developing (Video Tutorial) Read More

Digital Photography Developing (Video Tutorial)

Learn what digital developing is, the difference between Lightroom and Photoshop, and why Lightroom will help your photography.

Latest Equipment Articles

Sun Position Tracking Apps Read More

Sun Position Tracking Apps

These 5 apps, ranging in price from free to $8.99, are our top picks for tracking sun (and moon) light. Also ranging in complexity, some help you keep tabs on the ideal lighting of the day while...

Latest Learning Articles

25 Exhilarating Photos of Airplanes Read More

25 Exhilarating Photos of Airplanes

By land and by air, photo.net members have captured stunning shots of airplanes at soaring heights, performing incredible stunts, and in breathtaking locales.


D70 Flash does not fire

Haris Subacius , Jan 26, 2005; 12:13 a.m.

Upgraded my D70 to firmware B 1.0.3.

Two things as a result: - None of the images get tagged with Adobe RBG color profile - Flash does not fire after it pops up on auto modes and/or after I pop it up in manual-semiauto modes. A press othe flash button produces clicks even if the flash is already up--feels like the camera has no idea that the flash is already up.

Anybody experienced similar things.

Suggestions? I am really no looking forward to shipping it back to Nikon or to the dealer. The camera is only a few weeks in my possession.

Thanks!

Responses


    1   |   2     Next    Last

ci p , Jan 26, 2005; 04:25 a.m.

I don't think the flash problem is related to the upgrade. Exactly the same symptoms happened to me and required a Nikon fix.

Jay Miao , Jan 26, 2005; 07:50 p.m.

I have no experience with D70 as I don't own one yet, so no idea about the firmware upgrade. But I do know in general based on my electronics background that if you have immediately experienced differences or malfunctions from original working conditions after the upgrade, which have never by chance behaved like that in camera and are non-fixable by some simple operations such as 'reset' or 'power off/on', or equivalent. There must be an issue (bug) related to the firmware. So you have to either downgrade it to original or manufacturing version or another error-free proved of the firmware (if you're able to) or send it to authorized Nikon service get it resolved. Good luck.

Haris Subacius , Jan 26, 2005; 11:42 p.m.

Seems like it's a flash position sensor

I talked to Nikon people, performed a hard reset, downgraded and re-upgraded the firmware and I am at the end of the rope. It seemsl like the camera will have to travel back to the dealer for replacement/repairs.

If anyone experiences the same thing, Nikon told me that pressing the flash button on the side of the flash box should not produce a click if the flash is already up. My D-70 does, so the present diagnosis is that the camera sensor that is supposed to register the flash position is malfunctioning.

I'll post the outcome after I get this resolved.

Ken Hewitt , Feb 05, 2005; 05:00 a.m.

Bought a D70 in July and have just experienced the same problem with clicking etc. Anyone reolved their issues yet. I live in the UK so have to mail my D&0 back to the States for repair.

Haris Subacius , Feb 05, 2005; 11:01 p.m.

Mine's gone

I mailed mine back to the seller as it was within the 30-day exchange window. In my case, the camera also did not imprint the color space correctly. I set the JPEGs to be captured in Adobe RGB color mode, but they all invariably were recognized by Photoshop CS as regular sRGB.

Good luck with your camera. I am still waiting for mine to return.

Haris Subacius , Feb 10, 2005; 12:31 p.m.

Replacement does not work either

Well, I just received a replacement from Digital4Less. They returned the old outfit with the lense and included a new body in the same box.

I was happy until I inserted the CF card. The camera simply forze! The greed reading indicator light on the bottom of the back did not come on and start blinking like it did on the previous body. I took the card out and camera was reset back to the original state--CLOCK started blinking on the top LCD panel. Tried it with two different cards both of which worked fine on the previous body.

I've never been this unlucky. I buy a lot of computer electronics from the cheepest never-heard-of-it manufacturers and very very rarely have a problem. NOW, two defective Nikon bodies in the row! I am very surprised.

I am sticking with it and sending this one for replacement as well. I hope third time's the charm.

Haris Subacius , Mar 08, 2005; 04:04 p.m.

I got D-70 #3. Shot over 500 images in the past couple of weeks. Upgraded firmware to 1.0.3 version. Used custom curves.

So far so good. Knowck on wood...

John Julich , May 04, 2005; 11:41 a.m.

I am having the same difficulty with my New D-70. I don't want to ship mine out either.

John Julich , May 04, 2005; 11:44 a.m.

I am running B 1.02, so I believe the trouble is not firmware related.


    1   |   2     Next    Last

Back to top

Notify me of Responses