A Site for Photographers by Photographers

Community > Forums > Nikon > Nikon FE shutter stuck, mirror...

Featured Equipment Deals

Latest Equipment Articles

The Week in Photography News Read More

The Week in Photography News

November 15-21, 2014: Hear the latest goings-on in the photography world, from product releases to event and campaign announcements and more.

Latest Learning Articles

Introduction to Creating an Album in Lightroom - Part I (Video Tutorial) Read More

Introduction to Creating an Album in Lightroom - Part I (Video Tutorial)

Learn to create an album in the Book Tab of Lightroom that you can publish and present to clients.


Nikon FE shutter stuck, mirror won't come down.

Pablo Emilio Lafon , Aug 07, 2005; 03:56 p.m.

The mirror sticks up. The shutter will not fire. Batteries are ok. I tried to take a picture in b mode but it didn't work

Sorry about the spelling but english is not my first language.

Responses


    1   |   2     Next    Last

Gary Watson , Aug 07, 2005; 04:09 p.m.

Try setting the shutter speed to "M90."

Pablo Emilio Lafon , Aug 07, 2005; 04:12 p.m.

done that it didn't work

Joseph Linzner , Aug 07, 2005; 04:20 p.m.

Pablo I repair cameras for a living. The stuck mirror situation is quite common. Usual cause is the dampening foam strip along the edge of the viewing screening turning into a gooey mess and quite sticky. With a toothpick gently try and pry the mirror from the viewing screen in the pentaprism. If it does not release immediately, stop! The mirrior is very delicate and the return mechanism on the mirror box is likewise. Lastly take the batteries out for a minute. Then re-insert carefully. The mirror/shutter should release. Failing this is is time to visit the nikon repair centre.

Pablo Emilio Lafon , Aug 07, 2005; 04:39 p.m.

well none worked so I'm guessing the mirror mecanism must be damaged... that is something I cannot repair, but is it posible to do so just to know if I should seek out for help or just get a new cammera

Eric Sande , Aug 07, 2005; 07:07 p.m.

Are you able to move the film advance lever? Something that can happen to this style of camera is that things can get thrown out of sync, resulting in the conditions you describe.

When it happened to me, the guy that fixed it for me showed me what he did in case it ever happened again. Since the film advance lever wouldn't swing out in a normal film advance move, he removed the bottom plate of the camera. There was a "lever" of sorts engaging a toothed cog at the bottom of the film rewind mechanism. He moved it out of the way, cocked the shutter and everything was fine again. If your film advance lever won't move, this may be what's going on.

Ron West , Mar 27, 2007; 06:38 a.m.

Hi Folks, I had the same problem with my FG and by moving shutter speed dial to M90 it released the mirror which I cleaned and evidently the FG needs good batteries to release the mirror from all other speeds. Camera is working just fine now so thanks to all who posted possible solutions to sticking mirror problems...Ron

Gary Bruce BOWEN , Sep 04, 2007; 03:09 p.m.

Hi, and thanks to Eric Sande,

removing the bottom plate and pulling just marginally with very little force, pulled the stuck tooth out of the way of the cog on the film advance capstan with a fine pair of forcepts (you can tell it is the capstan as it has the tongue and groove for the MD12 motor drive facing you as you peer into the guts) I heard a click of sorts and then heard the mirror drop back into place, cocked/advanced and.... voila!! thanks Eric!

roy THOMAS , Jul 03, 2009; 08:06 p.m.

The Lord of Heaven, the God of all the earth, the one who gave His Only Son to die on the cross of Calvary, bless you.
I had the problem of a stuck mirror and the film advance lever would not move to allow loading of the film.
I am so happy that I followed the instruction of moving to the M90 position and was greeted by a sound from the camera and the Mirror fell into its rightful place.
A BIG THANK YOU TO YOU ALL.
ROY THOMAS.

MaĆ­ra Mendes , Jan 05, 2010; 04:13 p.m.

Just wanted to say thanks to all contributors. I had the same problem and just tried the M90 position, then took the batteries out for a few minutes and put them back again. Worked like a charm. Spared me of some serious headache!


    1   |   2     Next    Last

Back to top

Notify me of Responses