A Site for Photographers by Photographers

Community > Forums > Nikon > Modification/Repair/Service > My Film Advance Lever is...

Featured Equipment Deals

Latest Equipment Articles

GoSpike Review Read More

GoSpike Review

A simple gadget to help you with your outdoor photography, suitable for GoPro, compact, and DSLR cameras.

Latest Learning Articles

Interview with Environmental Photographer: Peter Essick Read More

Interview with Environmental Photographer: Peter Essick

A conversation with National Geographic photographer, Peter Essick, author of Our Beautiful, Fragile World.


My Film Advance Lever is Stuck! I am a Beginner! Please HELP!

Jane D , Aug 22, 2005; 01:36 a.m.

I recently bought the Nikon FM 10 manual SLR camera. I'm a complete beginner so I hardly knew what I was doing with it. I put in the batteries and followed the instructions to test it out. I moved the film advance lever to the ready position and then pressed the shutter release buton. The three LED lamps lit in the viewfinder. After that, I fiddled around with the lenses. I zoomed in and adjusted the focus and so forth. Then I tried out my seperate flashbulb that I had bought. I don't know what happened after that, but then the film advance lever got stuck in the ready position. I won't even go back to the original position now! And also, now when I look into the viewfinder and press the shutter release button, the lamp lights don't go on! I changed the batteries twice but nothing happened! I don't know what to do!

PS- my camera has no film in it.

Responses

Ken Dennis , Aug 22, 2005; 02:45 a.m.

What ever you do, DO NOT FORCE IT, it may have a piece of foam seal or a loose metal part like a screw or something stuck in the gearing!

Take it to a shop, and have them check it over for you!

Good luck!

Ken.

Ramon V (California) , Aug 22, 2005; 02:48 a.m.

open the back again then close it. make sure that when you wind the film advance lever it goes all the way until it stops and let go. it will stop back into the ready-to-shoot position. push it back into the body when not ready to shoot or before you do anything like attaching accessories.

Robert Lai , Aug 22, 2005; 03:03 a.m.

It does sound as if you haven't fully cocked the film advance lever. Try gently to push the lever forward until it won't go anymore. Then, the shutter should fire when you press the shutter release.

I won't lecture you, but with any new acquisition which has some degree of complexity, it does pay to sit down with the manual and go through everything once.

Scott Warn , Aug 23, 2005; 06:45 p.m.

What does your film counter say? If you've hit the end of the roll of film, the wind lever won't allow you to cock the shutter fully because the film is holding it back. If this is your situation, press the rewind button on the bottom of the camera, hold it in, and finish cocking the shutter by winding the wind lever.

Tip, next time watch your film counter and rewind the film when you hit either 24 or 36. Trying to get an "extra" frame can either damage the film, or the camera, if you try and force it and your much better off just staying to the exposure count that's on the film.

Michael Christensen , Aug 24, 2005; 01:08 p.m.

Sounds like the film was improperly loaded .. if you've already taken a few pictures, they may of course be okay, but the film may have jammed around the take-up spool.

Assuming you have no electrical issues .. I'd take it to a camera shop that has a dark room or changing bag .. have them merely open up the camera and remove the film. If they are careful, it should not even damage the shots you've already taken.

then take a "dummy roll of film" .. or buy a cheap roll of expired film and practice inserting and going through the loading process until you've figured out the easiest way to preclude film loading problems.

I once loaded a number of rolls of film under stress, during a model shoot and in my haste, improperly loaded one roll, took 14 pictures before the problem appeared .. had no changing bag with me in the field, but .. ended up opening the film back in a changing bag and carefully pushing the exposed film back into the film cannister .. only lost two shots .. but learned my lesson about "attention to detail when loading film."

Michael Christensen , Aug 24, 2005; 01:15 p.m.

Ok, well, now I see "has no film in it" .. well, it sounds as if the film advance did not fully cock the shutter .. hummm, plastic gears, .. don't force anything .. take it to the shop and let them evaluate it ..

Back to top

Notify me of Responses